Brake wiring help

Questions about towing your boat or boats that can be towed.

Brake wiring help

Postby TSloan » Mon Jun 20, 2016 8:44 pm

Hey guys...Im hoping someone might be able to help. I replaced the wiring and tail lights with a new set today..has complete new wire and plug hookup as well as the lights themselves.
I wired the lights up as per instructions..simple nuff..got good ground on each light as well as plug ground.
Problem Im having is my right turn signal or brake light wont work..the tail light works though. Tried swapping the wires around just in case, and thats not it... \
also noticed when I turn the lights off on the vehicle, leaving the trailer still plugged in, the tail light still glows a little (element still burns slightly)

Left side light/brake/turn works perfect...so Im confused here on what to check next..any ideers ? :?
TSloan
 
Posts: 8
Joined: Mon May 09, 2016 8:17 am

Re: Brake wiring help

Postby Chris_in_Texas » Mon Jun 20, 2016 9:37 pm

Sounds like a grounding issue. If they are bulb based lights then the light bulb can be in backwords can cause issues as the contacts don't line up correctly.
Thanks, Chris

2012 - Regal 35 Sports Coupe - Twin VP 5.7GiCE-300-P - DP-SA - SOLD
2011 - Sea-Doo RXT260s - 1503HO Rotax 4TEC
2007 - Regal 3060 - Twin VP 5.0OSi - XDP - SOLD
2002 - Crownline 230BR VP 8.2GSiPEFS - DP-SM - SOLD
User avatar
Chris_in_Texas
2013 Regal Owners MULTIPLE Donator!
2013 Regal Owners MULTIPLE Donator!
 
Posts: 4395
Joined: Wed Mar 05, 2008 8:56 pm
Location: Frisco, TX (DFW Area)

Re: Brake wiring help

Postby cbsmith » Tue Jun 21, 2016 4:46 am

The one light now working could also be an issue with the truck wiring. You can take it to a place that installs trailer hitches to be checked or buy your own tester on Amazon or at Harbour Frieght.
2014 Regal 1900
2010 Sea-Doo GTX 155
2007 Sea-Doo Wake 215
cbsmith
 
Posts: 406
Joined: Sun Nov 02, 2014 4:21 pm
Location: New Brunswick, Canada

Re: Brake wiring help

Postby Rob » Tue Jun 21, 2016 4:57 am

I had a problem a few years ago with a GMC Yukon I used to own that sounds similar to yours. Turns out that in that vehicle, there was the main fuse box under the hood and then an accessory fuse box in the side of the dash, seen only when the driver door was open. In there were fuses for the trailer harness, and left and right trailer light functions were fused separately. That was a factory installed harness, so an add on could be set up differently. Could that be part of the issue?
Thanks,

Rob
Finger Lakes Region, NY
'15 Regal 2300, VP 300, DPS
'98 Sea Ray 190 Bowrider, Merc 5L, Alpha I, 21" SS prop (sold)
'00 Sea Doo GTX Millenium (sold)
User avatar
Rob
 
Posts: 64
Joined: Mon Apr 25, 2016 7:30 pm
Location: Finger Lakes Region, NY


Return to Tow Your Boat

Who is online

Users browsing this forum: No registered users and 1 guest

cron