Is this normal on an alpha one

General repair/maintenance/upgrade information exchange.

Is this normal on an alpha one

Postby pyro225 » Fri Jul 20, 2018 12:30 pm

So boat looked nearly beached so I tilted the drive up and it is covered in clay (hopefully didn’t do any damage the bed is very soft clay.) anyway when I tilted it up I noticed so water coming out of the drive here on the attached pic - is that normal? Should I worry?

Cheers

0215F55A-76CF-4F01-BDCC-AEFBA37AA2AD.jpeg
Seems to be about 1mm by 3mm I’m the red circle
2005 Regal 1800 LSR 1.7DTI
pyro225
 
Posts: 142
Joined: Wed Jul 22, 2015 3:16 pm

Re: Is this normal on an alpha one

Postby pyro225 » Fri Jul 20, 2018 12:40 pm

2005 Regal 1800 LSR 1.7DTI
pyro225
 
Posts: 142
Joined: Wed Jul 22, 2015 3:16 pm

Re: Is this normal on an alpha one

Postby Bt Doctur » Fri Jul 20, 2018 10:25 pm

If you start running hot you will know why.
Bt Doctur
 
Posts: 215
Joined: Sun Jul 19, 2015 12:44 pm
Location: central New Jersey

Re: Is this normal on an alpha one

Postby pyro225 » Sat Jul 21, 2018 9:57 am

So it’s normal?
2005 Regal 1800 LSR 1.7DTI
pyro225
 
Posts: 142
Joined: Wed Jul 22, 2015 3:16 pm

Re: Is this normal on an alpha one

Postby gofast24 » Sat Jul 21, 2018 11:22 am

When you tilt the OD all of the way up some sea water will drain back out of both the lower unit intake and prop hub. If I were you I would just pull boat out, wash down out drive and prop outlet with some good fresh high pressure water (hose) and then connect cuffs to the water inlet to flush out any clay that may have gotten into you cooling system! Looks like you really got deep int the mud!!
gofast24
2001 Regal 4160
Twin VP 8.1GSiI V Drive Inboards
Lake Lanier, GA
gofast24
 
Posts: 2430
Joined: Mon Jan 26, 2015 12:03 pm
Location: Lake Lanier GA

Re: Is this normal on an alpha one

Postby Me2660 » Mon Jul 23, 2018 4:02 pm

Item 6 in Merc Manual: Make sure that speedometer pitot tube, trim tab cavity vent hole,
and trim tab cavity drain passage are unobstructed.

Thanks
Mark
Attachments
alpha.jpg
alpha.jpg (15.97 KiB) Viewed 523 times
2001 Regal 2660 Commandore
User avatar
Me2660
 
Posts: 45
Joined: Mon Oct 13, 2014 1:06 pm
Location: Chicago

Re: Is this normal on an alpha one

Postby pyro225 » Fri Jul 27, 2018 9:15 am

Ahhh probably why the pitot stopped working! No matter now I have gone gps!

Also given her a clean
2005 Regal 1800 LSR 1.7DTI
pyro225
 
Posts: 142
Joined: Wed Jul 22, 2015 3:16 pm

Re: Is this normal on an alpha one

Postby Regal3260 » Mon Jul 30, 2018 8:39 am

Wow. How did the drive get covered with clay so high?

Mark
Regal 3260
Toronto, ON
User avatar
Regal3260
2013 Regal Owners MULTIPLE Donator!
2013 Regal Owners MULTIPLE Donator!
 
Posts: 657
Joined: Mon Oct 04, 2010 8:17 pm
Location: Toronto, ON


Return to Repair Shop

Who is online

Users browsing this forum: No registered users and 30 guests

cron