Blower Not Working Regal 2550

General repair/maintenance/upgrade information exchange.

Blower Not Working Regal 2550

Postby sod11 » Sun Aug 19, 2018 8:16 pm

I have a 2014 Regal 2550 with less than 100 hours . The engine compartment blower is not working. Checked switch and fuse, both OK. Is there a another protective device between the control panel( ie control switch) and motor? Where is the blower ? Checked manual and still unable to locate the blower.
Dave
sod11
 
Posts: 7
Joined: Mon Jun 01, 2015 8:52 am

Re: Blower Not Working Regal 2550

Postby SGilbert » Mon Aug 20, 2018 8:05 am

The blower is inline with one of the 3-4" tubes. Check the connections attached to it.
Steve
"L'Chiam"
'00 Regal 2660 (2765) T/Merc 4.3's
User avatar
SGilbert
2012 Regal Owners MULTIPLE Donator!
2012 Regal Owners MULTIPLE Donator!
 
Posts: 948
Joined: Sun Jan 06, 2008 11:50 pm
Location: South Bend, IN; slipped in Michigan City, IN

Re: Blower Not Working Regal 2550

Postby gofast24 » Mon Aug 20, 2018 10:51 am

Yes, the engine room blower is in th engine room but most likely mounted high so not so obvious to see it. Try locating the outlet of the blower (3" or 4" flex hose) where it exits the hull and trace the hose backwards. As the fuse and/or circuit breaker hasn't tripped I have to wonder if you helm switch or the wiring/connections to the blower has failed? We have one of two engine room blowers that is getting noisy. With our gen set the blowers automatically turn on whenever starting/running the gen set so the blowers see a lot of operating hours. As your fuse or circuit breaker hasn't tripped/blown could be a open winding or bad connection to the blower and not the blower itself. When you find the blower turn the helm switch on and check the voltage at the blower motor to see if your getting + 12 VDC there. Let us know what you find, you need to get the blower operating again to evacuate any gasoline fumes from the engine room before starting the engine (s) !
gofast24
2001 Regal 4160
Twin VP 8.1GSiI V Drive Inboards
Lake Lanier, GA
gofast24
 
Posts: 2391
Joined: Mon Jan 26, 2015 12:03 pm
Location: Lake Lanier GA

Re: Blower Not Working Regal 2550

Postby sod11 » Tue Sep 04, 2018 8:41 pm

Yes, the blower is located inside a 4" flexible hose near top of engine in the engine compartment. The blower was white and sort of looks like a large hose clamp. Opened hose , able to turn blades of fan OK, so not a bearing issue. Measured DC resistance ( ie ohms) measured 22 . Thought that was the problem. Purchased new in line blower and measured resistance , measured anywhere from 0.5 ohm to about 22 ohms while turning fan blades. Probably, measuring reflected rotor resistance . Bottom line motor OK. So, now what ? Noticed that a wire was off the fire extinguisher ( auto deluge), reconnected wire and blower worked . Forgot to say, that I measured 12 volts on "both "pins to the fan motor , with blower disconnected, which did not make sense. 12 volts with blower switch in one position and 10 volts on both pins with blower switch in the other position (ie off/on) That was telling me that three was something in series . I was just about to begin tracing wires when I noticed a. wire off the fire extinguisher which was very close( about 3" ) from the in line blower. Thanks to all who commented and to those who expressed interest. I tried to summarize my findings in consideration of those who may have problems in the future.
Dave
sod11
 
Posts: 7
Joined: Mon Jun 01, 2015 8:52 am

Re: Blower Not Working Regal 2550

Postby gofast24 » Thu Sep 06, 2018 12:27 pm

Yes, most USCG certified vessels have a series switch in the fire extinguisher wiring that will disconnect the blower if there is a fire detected. No need to explain why.
Also, with a permanent magnet motor, when turning the motor (fan blades), it will produce voltage and not read the actual winding resistance doing that. If yu are going to measure resistance of a DC motor with permanent magnet field dont turn the motor shaft. So what did you do about the fire extinguisher switch in series with the blower motor?
gofast24
2001 Regal 4160
Twin VP 8.1GSiI V Drive Inboards
Lake Lanier, GA
gofast24
 
Posts: 2391
Joined: Mon Jan 26, 2015 12:03 pm
Location: Lake Lanier GA


Return to Repair Shop

Who is online

Users browsing this forum: Google Adsense [Bot] and 19 guests