Power Steering Problems - VP 8.1, 2007 2700

General repair/maintenance/upgrade information exchange.

Power Steering Problems - VP 8.1, 2007 2700

Postby Muddy Blues » Tue Aug 07, 2018 6:58 am

The power steering on my boat started to feel "chunky" this summer. I noticed it, but did not give it much thought. Recently the PS started to make whining noises (noise correlates with turning the steering wheel). On Saturday, we added a bottle of fluid and the noise went away and the wheel felt normal again. However, the noise returned at the end of the day. On Sunday, all was fine again at the start of the day. However, at the end of the day, the noise was back and was louder and more constant. By the time I returned to the slip, I was getting no assist from the PS (and no noise).

Anyway, a few questions:

  • What is mostly likely the needed fix here? New PS pump? Could this be a belt or hose issue?
  • Given that I have a rear opening engine hatch, and the PS pump is on the front of the engine, any chance this repair can be done while the boat is in the slip?
2007 Regal 2700, 8.1 VP DP
Lake Geneva, WI
Muddy Blues
 
Posts: 68
Joined: Sat Jul 03, 2010 10:22 am

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby bbbrr04 » Tue Aug 07, 2018 7:06 pm

I have changed a pump on one of my volvos in port. i had to revert back to my days of being 50 lbs lighter and an acrobat for Barnum Bailey, but got it done only dropping one bolt into that unforgiving invisible hole that sucks up the parts you drop. I did find an old pair of readers on the back of the engine also. Good luck. p.s. is the fluid in the clear tank on the stern foamy?
Rodney and Becca
Peoria Illinois Peoria Boat Club
1999 Regal Commodore 2660
Volvo 4.3s
User avatar
bbbrr04
 
Posts: 42
Joined: Fri Apr 17, 2015 1:00 pm
Location: Peoria Boat Club Peoria Illinois

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby Chris_in_Texas » Tue Aug 07, 2018 11:20 pm

If it has run dry then most likely that is the issue and a new pump would be in order I believe as they will burn up. Others can chime in as well. Where did the fluid go? That should be the first issue. They are closed systems and shouldn't loose any fluid. If you haven't changed the surpentie belt in a while you might be due, but again fluid loss wouldn't be caused by a belt. :mrgreen: That would squeal loudly for a loose belt.
Thanks, Chris

2012 - Regal 35 Sports Coupe - Twin VP 5.7GiCE-300-P - DP-SA - SOLD
2011 - Sea-Doo RXT260s - 1503HO Rotax 4TEC
2007 - Regal 3060 - Twin VP 5.0OSi - XDP - SOLD
2002 - Crownline 230BR VP 8.2GSiPEFS - DP-SM - SOLD
User avatar
Chris_in_Texas
2013 Regal Owners MULTIPLE Donator!
2013 Regal Owners MULTIPLE Donator!
 
Posts: 4408
Joined: Wed Mar 05, 2008 8:56 pm
Location: Frisco, TX (DFW Area)

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby Muddy Blues » Wed Aug 08, 2018 1:22 pm

bbbrr04 wrote:p.s. is the fluid in the clear tank on the stern foamy?


I don't know if it was foamy - the tank is hard to see, and I was not the person who added the fluid. Are you thinking that air is getting into the fluid?

Chris_in_Texas wrote:If it has run dry then most likely that is the issue and a new pump would be in order I believe as they will burn up. Others can chime in as well. Where did the fluid go? That should be the first issue. They are closed systems and shouldn't loose any fluid. If you haven't changed the surpentie belt in a while you might be due, but again fluid loss wouldn't be caused by a belt. :mrgreen: That would squeal loudly for a loose belt.


I don't know where the fluid is going, and I did not notice any in the bilge (I did not look closely, it could be pooled up underneath the engine). I also have not noticed a sheen on the water, so hopefully the bilge pump is not pumping it overboard.

My goal was to avoid a haul out, but after speaking with my repair shop, a haul out is the proper solution. They will most likely have to remove the engine cover, which would be hard to do in the slip. They also can clean the bilge while on the hard deck as well. I assume I will get a new pump, belt, and maybe hoses.

Thanks for the input.....
2007 Regal 2700, 8.1 VP DP
Lake Geneva, WI
Muddy Blues
 
Posts: 68
Joined: Sat Jul 03, 2010 10:22 am

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby Muddy Blues » Thu Aug 09, 2018 2:15 pm

Just heard back from the repair shop - the problem was a plastic cap/plug that cracked, allowing the PS fluid to escape. The pump appears to be undamaged and is working fine with the part replaced and fluid refilled. Bilge has been cleaned and boat will be splashed this weekend.
2007 Regal 2700, 8.1 VP DP
Lake Geneva, WI
Muddy Blues
 
Posts: 68
Joined: Sat Jul 03, 2010 10:22 am

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby cbsmith » Thu Aug 09, 2018 6:05 pm

You have to love an easy cheap repair!
2014 Regal 1900
2010 Sea-Doo GTX 155
2007 Sea-Doo Wake 215
cbsmith
 
Posts: 409
Joined: Sun Nov 02, 2014 4:21 pm
Location: New Brunswick, Canada

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby bbbrr04 » Sat Aug 11, 2018 10:37 am

Muddy Blues wrote:Just heard back from the repair shop - the problem was a plastic cap/plug that cracked, allowing the PS fluid to escape. The pump appears to be undamaged and is working fine with the part replaced and fluid refilled. Bilge has been cleaned and boat will be splashed this weekend.


That is always a great feeling. I love when it is that simple and you have a mechanic that is honest and knowledgeable. They are hard to find in our area.
Rodney and Becca
Peoria Illinois Peoria Boat Club
1999 Regal Commodore 2660
Volvo 4.3s
User avatar
bbbrr04
 
Posts: 42
Joined: Fri Apr 17, 2015 1:00 pm
Location: Peoria Boat Club Peoria Illinois

Re: Power Steering Problems - VP 8.1, 2007 2700

Postby Muddy Blues » Mon Aug 13, 2018 12:09 pm

The other cool thing is the quick turn around. My local Regal dealer said they are booked up for several weeks, and since I don't store off season with them, they won't make a service call to the marina (their truck is there almost every day). My local non-dealer marine service shop got me in and during the week, so I did not lose any weekend time.
2007 Regal 2700, 8.1 VP DP
Lake Geneva, WI
Muddy Blues
 
Posts: 68
Joined: Sat Jul 03, 2010 10:22 am


Return to Repair Shop

Who is online

Users browsing this forum: Google Adsense [Bot], tombeattie and 29 guests