No power to trim tabs or trim to raise motor

Site issues and suggestions for improvement.

No power to trim tabs or trim to raise motor

Postby Statonville » Mon May 15, 2017 11:22 am

I have a 1995 Regal Destiny 24, deck boat. All was working fine yesterday until we were taking it out of the water then we realized for some reason we could not raise the motor. No noise when pressing up or down. Then, for curiosity I tried the trim tabs and they weren't working either. We checked all the fuses in the panel under the steering wheel and all is good. We raised the cover on the motor and saw some red, button looking things that don't push in. Thinking these must be a breaker of some sort that goes to who knows what. Can anyone give me some advise? A starting point?
Statonville
 
Posts: 1
Joined: Mon May 15, 2017 10:54 am

Re: No power to trim tabs or trim to raise motor

Postby xixp » Wed May 17, 2017 10:56 pm

My trim tabs sttoped working all of a sudden two weeks ago and i tracked down the problem to a poor ground of the trim tabs pump module. May be you have two untelated problems but check the grounds besides the positive terminals. Trim tabs are pretty simple to trouble shoot so i would start with them and they might liead to the issue of the engine trim pump. (Get the trim tabs electrical drawing from the manufacturer websites and get a multimeter).

Let us know what you find.
2016 SC 35 , "Phoenix"
2010 3760 (sold)
User avatar
xixp
 
Posts: 286
Joined: Wed May 23, 2012 11:42 am
Location: Miami,FL


Return to Suggestion/Problems

Who is online

Users browsing this forum: No registered users and 1 guest