CO Detector Not Working

New, and old Regal boat model information and questions.

CO Detector Not Working

Postby TechRider » Mon May 28, 2018 7:31 am

Does anyone know how to fix the fuse being tripped in the picture below?

The CO detectors are not working and the CO monitor fuse in the picture is always out. When pressed in it does not stay in like the others.

Do I open the panel and change a fuse?
Attachments
20180528_082517-557x478.jpg
2018 Regal 33 Express
User avatar
TechRider
 
Posts: 68
Joined: Mon Feb 13, 2017 9:20 pm
Location: CT

Re: CO Detector Not Working

Postby ImRich » Mon May 28, 2018 8:39 am

If your breaker keeps popping something is drawing to much current. You need to find the problem, perhaps a bad detector, or a shorted wire?
Rich
2005 - 3560
Unbelievable!
NH
ImRich
 
Posts: 957
Joined: Sat Apr 13, 2013 1:06 pm
Location: NH USA

Re: CO Detector Not Working

Postby Chris_in_Texas » Mon May 28, 2018 9:05 am

Yes something has gone wrong to keep tripping the breaker. In theory that should be about a 2A breaker. While they do go bad from time to time, most likely there is a problem in the CO unit itself or wiring. Simply disconnect the power from the CO detector (small plug) and then press in the breaker reset and see if it stays in. If so you found your problem. You most likely have more than one CO detector as well so disconnect them all to start and then plug one by one in to see when it trips. If having all the detectors unplugged and it still trips that means someone has put something else on that circuit. If it doesn't latch closed (ON) then it could be a bad breaker. Remove the panel and see the current value on it, and replace the breaker.
Thanks, Chris

2012 - Regal 35 Sports Coupe - Twin VP 5.7GiCE-300-P - DP-SA - SOLD
2011 - Sea-Doo RXT260s - 1503HO Rotax 4TEC
2007 - Regal 3060 - Twin VP 5.0OSi - XDP - SOLD
2002 - Crownline 230BR VP 8.2GSiPEFS - DP-SM - SOLD
User avatar
Chris_in_Texas
2013 Regal Owners MULTIPLE Donator!
2013 Regal Owners MULTIPLE Donator!
 
Posts: 4305
Joined: Wed Mar 05, 2008 8:56 pm
Location: Frisco, TX (DFW Area)

Re: CO Detector Not Working

Postby TechRider » Wed May 30, 2018 6:14 am

Thanks for the replies.

The breaker would never reset. So it needed to be replaced. It was always sticking out.

It is a pain to change those breakers and they are not available at most places. I would prefer to have the regular ATC type of breaker.

Waiting for the dealer to get a breaker and will use cary on CO detectors for now.
2018 Regal 33 Express
User avatar
TechRider
 
Posts: 68
Joined: Mon Feb 13, 2017 9:20 pm
Location: CT


Return to Boat Models

Who is online

Users browsing this forum: cbsmith and 15 guests